[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Game announcements on LGDC



Tomas Andrle wrote:

>> Hence, my functions tend to be concise: MoveSprite, ChangeSpriteShape,
>> SetSpriteMotion, etc. :)
>
>In this particular case, I'd prefer sprite_move, sprite_change_shape,
>sprite_set_motion, all placed in "sprite.*". Nuff said...:)

namespace GAMES
{
class Sprite
{
public:
void Move (...);
};
} 

;-)

>> one big .CPP file greater than 300K in size. I don't think we should bar
>> the announcement of something interesting or useful if someone feels the
>> author didn't comment it properly (this is kinda one of my sins :)) or
>> the function names aren't descriptive enough. 
>> 
>
>I propose something like the happypenguin.org ratings with 0..5 stars :-))) or
>just a Warning that it's very _hard_ to read the code.

A warning or some kind of comment should do best.


	Christian

--

Drive A: not responding...Formatting C: instead