Stephanie Lockwood wrote:
> The 2.7 C++ compiler is allegedly lacking support of many modern C++[snip]
Indeed, 2.7 wasn't fully compliant with the "standard" that existed
when it was released. . . .All of those areas except
for namespaces are supposed to be basically up to snuff in 2.8.
My impression is a re-install is usually simpler than an upgrade to glibc[snip]
anyways, assuming it's an ordinary user who didn't have to put too much
effort into the configuration to begin with.
In summary, my opinion is that we should be consistant between libc/glibc, butI have to admit that I am no expert on the compiler issues, but given the above postulates that (i) v. 2.7 is incomplete and non-compliant w/ standards/ and (ii) upgrading from 2.7 to 2.8 is DIFFICULT (even for an ordinary user since new libraries may require installing new binaries), AND (most important) (iii) the goal is to make Linux easy for unsophisticated users, AND (iv) (my postulate based on (i)) 2.7 will be obsolete before too long, I would think 2.8 is the way to go.
I don't know whether it's worth the trouble or not, somebody else who knows
what cool applications have taken to requiring g++ 2.8 should decide that :-)
Just my $0.02 worth . . .
Andreas F. Pour