[Author Prev][Author Next][Thread Prev][Thread Next][Author Index][Thread Index]

Tor with DynDNS on FC3

Problem:  Can't get tor run due to it not resolving or understanding that the IP address is a dyndns one

I've installed Tor on a local server at my home running Fedora Core 3.  I've edited the torrc files to act only as a server.  I use DynDNS to maintain a consistant name resolution.  In the notices.log I get this message repeatedly every few minutes. 

Jul 29 10:35:30.648 [warn] second_elapsed_callback(): Your server (_my ip address_:9030) has not managed to confirm that its DirPort is reachable. Please check your firewalls, ports, address, /etc/hosts file, etc.
Jul 29 10:43:52.679 [notice] connection_edge_process_end_not_open(): Have tried resolving or connecting to address '[scrubbed]' at 3 different places. Giving up.

I'm sure that I have forwarded the correct ports through my firewall to the tor server.  Here is what my torrc file looks like:

SocksPort 9100
RunAsDaemon 1
DataDirectory /var/lib/tor/keys
ControlPort 9051
Nickname _my server nickname_ [properly registered]
ORPort 9001
DirPort 9030

This should be pretty standard from what I understand.  I even used the web based wizard to try and make the torrc file for me and I'm getting the same error. 

On a windows machine, I can run the tor client and it works just fine as a server but I haven't been able to get it running on linux.  Other people have had this problem as well but I haven't seen a resolution.  Can someone shed any insight?