[Author Prev][Author Next][Thread Prev][Thread Next][Author Index][Thread Index]

Re: Problems with cvs?

On May 22, 2005, at 4:39 PM, yancm@xxxxxxxxxxxxxxxx wrote:

The last couple of days I have been getting error messages when I try to
update my source tree from cvs. I received connection refused for a while,
but now I am getting:

cvs update: Updating .
cvs update: failed to create lock directory for `/home/or/cvsroot/tor'
(/home/or/cvsroot/tor/#cvs.lock): Permission denied
cvs update: failed to obtain dir lock in repository `/home/or/ cvsroot/tor'
cvs [update aborted]: read lock failed - giving up

Is it just me?

No, it is not just you. I am getting the same error. MacOSX v. 10.4 has the following permissions on /tmp:

sarah:~ peter$ ls -ld /tmp
lrwxr-xr-x   1 root  admin  11 May 13 19:47 /tmp -> private/tmp
sarah:~ peter$ ls -ld /private/tmp
drwxrwxrwt   6 root  wheel  204 May 22 10:01 /private/tmp

The final "t" is the "sticky bit."  From the MacOSX 10.4 man pages:

"A directory whose `sticky bit' is set becomes an append-only directory, or, more accurately, a directory in which the deletion of files is restricted. A file in a sticky directory may only be removed or renamed by a user if the user has write permission for the directory and the user is the owner of the file, the owner of the directory, or the super-user. This feature is usefully applied to directories such as /tmp which must be publicly writable but should deny users the license to arbitrarily delete or rename each others' files."

So fink should be able to write to /tmp, but I am getting the same error message.

Alexander Hansen wrote:

You're really only supposed to run selfupdate-cvs to change your update mode--you should now be set up such that a plain selfupdate uses cvs (this didn't cause your problem).

/tmp should let everybody write to it.  Check via

ls -ld /tmp /private/tmp

Thanks Alexander. So now that I have enabled CVS updating, will the process work OK now?