[Author Prev][Author Next][Thread Prev][Thread Next][Author Index][Thread Index]

Exit-node keeps .$mynode.exit in dns name


I tried to check one of my exit nodes by using firefox. Firefox is using
tor as socks4a so it resolves dns-names using tor. I changed
network.proxy.socks_remote_dns to true from about:config.

My setup with exit node in question is following:

Server with firewall&router&transparent_squid <-NAT-> ServerRunningTor

Traffic from outside comes to firewall, it NAT's it by port to server
running Tor, Tor's traffic is routed through the same firewall and if
destination port is 80 traffic goes through transparent proxy running on
the firewall-server.

My problem is following: I typed http://whitehouse.gov.$mynode.exit (where
$mynode was my exit nodes name) in address bar, waited a moment and got
following error message from the server running transparent Squid proxy:

The requested URL could not be retrieved
While trying to retrieve the URL: http://whitehouse.gov.$mynode.exit/
The following error was encountered:
    Unable to determine IP address from host name for
The dnsserver returned:
    Name Error: The domain name does not exist.
This means that:
 The cache was not able to resolve the hostname presented in the URL.
 Check if the address is correct.
Your cache administrator is proxy@xxxxxxxxxxxxx
Generated Tue, 15 May 2007 22:32:24 GMT by xxx.xxxxxx.xx (squid/2.6.STABLE5)

I'm pretty confused here. Why does exit node send the .$mynode.exit when
trying to resolve dns-name?

I tried couple other random exit nodes and they worked fine.