[Author Prev][Author Next][Thread Prev][Thread Next][Author Index][Thread Index]

Re: Compile Error report

On Mon, 28 May 2007 23:47:52 -0400
Nick Mathewson <nickm@xxxxxxxxxxxxx> wrote:

> > 
> Try re-running configure on the latest svn?
> Is HAVE_STRUCT_IN6_ADDR is defined in orconfig.h?
> Where is struct in6_addr defined in your system headers?
> yrs,
> -- 
> Nick Mathewson

Tried re-configure the project by running ./autogen.sh, still the same
error messages. I traced and commentted the struct definition in
compat.h and then successfully compiled the project.

It seems that the script didn't find the definition that exist in mingw
compile system.

Even with that small changes there's still errors:

d:/CompileProject/tor-mingw/tor-svn/tor/src/common/compat.c:911: undefined reference to `inet_aton'
collect2: ld returned 1 exit status
make[3]: *** [tor.exe] Error 1
make[3]: Leaving directory `/d/CompileProject/tor-mingw/tor-svn/tor/src/or'
make[2]: *** [all-recursive] Error 1
make[2]: Leaving directory `/d/CompileProject/tor-mingw/tor-svn/tor/src'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/d/CompileProject/tor-mingw/tor-svn/tor'
make: *** [all] Error 2

That line reads:
	if (inet_aton(eow, &in) != 1)

I wonder if "inet_aton" should be changed to "tor_inet_aton".

Li-Hui Zhou <lhzhou@xxxxxxxx>