[Author Prev][Author Next][Thread Prev][Thread Next][Author Index][Thread Index]

Re: [tor-talk] Firefox with Tor on Android?

On 2015-05-21, at 09:27, Nathan Freitas wrote:

> On Wed, May 20, 2015, at 03:44 PM, Jens Lechtenboerger wrote:
>> On 2015-05-19, Nathan Freitas wrote:
>> > Have you tried the latest "Apps VPN" feature that tunnels all
>> > device traffic through Tor without root?
>> I just tried that with 15.0.0-RC-3, but failed to get VPN working.
>> If I klick âAppsâ first, and start Tor afterwards, no circuit gets
>> built.  In the log I repeatedly see âThe connection to the SOCKS5
>> proxy server at just failed.â
> That is the way to do it (click Apps first, then start Tor). Make sure
> to disable all root, transparent proxying options, and also flush/remove
> all transproxy rules in the "Debug" section of Orbot settings.

I did that, but without success.

The logs show something like the following:
WARN The connection to the SOCKS5 proxy server at
just failed. Make sure that the proxy server is up and running.

The mentioned socks port is open, in addition to 9050.
Port 9050 is an IPv4 socket, while 10853 is an IPv6 one.

When I capture the traffic, on the loopback interface I see that SYN
packets to are immediately answered by RST.
Indeed, with telnet I can connect to port 10853 on ::1, but not on (connection refused).

Frankly, this is entirely new to me.  On my GNU/Linux PC such a
different handling of ::1 and is not visible to me.

If Iâm not mistaken, either the proxy should bind to or
Socks5Proxy in torrc.custom needs ::1.

Best wishes
tor-talk mailing list - tor-talk@xxxxxxxxxxxxxxxxxxxx
To unsubscribe or change other settings go to