[Author Prev][Author Next][Thread Prev][Thread Next][Author Index][Thread Index]

Re: [tor-talk] .onion address for SSH no longer works

On 19 September 2011 22:04, cmeclax-sazri
<cmeclax-sazri@xxxxxxxxxxxxxxxx> wrote:
> On Monday 19 September 2011 18:11:55 Advrk Aplmrkt wrote:
>> Hello,
>> I've set up Tor on my server, including a SSH hidden service, replete
>> with its *.onion address. I've been able to remotely login via the
>> hidden SSH service.
>> But last week, after a package update to tor- (I installed tor
>> from official repo), and a tor restart, I get a connection refused
>> error when trying to access the hidden service. I checked and my tor
>> service is running normally, no errors in tor logs either...
>> How do I troubleshoot this issue?
>> Thanks.
> 1. Try to connect to the SSH server directly from the box running Tor, without
> going through Tor. "telnet localhost 22" (assuming your sshd is using the
> usual port; sometimes people map different ports when running hidden
> services) will tell you if sshd is up without actually logging in.
> 2. Run tcpdump or wireshark on the server looking for any activity on port 22;
> while it's running, try to connect to the hidden service. If tor and sshd are
> on the same computer, you need to watch the loopback interface.
> 3. Rename the hostname file, leaving the private_key untouched, in the hidden
> service folder, and restart tor. It should create an identical hostname file.
> You can add "SafeLogging 0" to torrc to tell tor to show you the addresses of
> hidden services it's failing to connect to. Set it to 1 when you've fixed the
> problem.
> cmeclax

OK. I've tried the above and they seem fine. In fact connecting to the
tor hidden SSH service worked briefly.

Unfortunately, I am getting the same error I got before:

Tor starts fine with:

"Starting tor: Sep 20 20:41:00.014 [notice] Tor v0.2.2.33
This is experimental software. Do not rely on it for strong anonymity.
(Running on Linux x86_64)
Sep 20 20:41:00.016 [notice] Your ContactInfo config option is not
set. Please consider setting it, so we can contact you if your server
is misconfigured or something else goes wrong.
Sep 20 20:41:00.019 [notice] Initialized libevent version
1.4.13-stable using method epoll. Good.
Sep 20 20:41:00.019 [notice] Opening OR listener on
Sep 20 20:41:00.020 [notice] Opening Directory listener on
Sep 20 20:41:00.020 [notice] Opening Socks listener on
Sep 20 20:41:00.021 [notice] Opening Control listener on
/usr/bin/torctl start: tor started"

After a few seconds, I check via "service tor status", and get:

"PID file (/var/run/tor/tor.pid) present, but tor (29865) not running"

I edited torrc to log errors, warnings, and notices, there are no
abnormalities logged... it seems that tor just stopped. This has been
happening in the past, and is still happening now after the recent
update to Tor v0.2.2.33. "service tor restart", nor complete system
reboot helps...

BTW, I am running Scientific Linux 6.1, and used "yum install tor"
from the following repo:

name=Tor and Vidalia

Can anyone help with this? I can't even begin testing the hidden
service before getting tor running first..... and this problem has
been bugging for the past two months... Thanks.
tor-talk mailing list