[Author Prev][Author Next][Thread Prev][Thread Next][Author Index][Thread Index]
[tor-bugs] #30769 [Core Tor/Tor]: Rename one of the two sendme.h files
#30769: Rename one of the two sendme.h files
------------------------------+--------------------------------
Reporter: nickm | Owner: (none)
Type: defect | Status: new
Priority: Medium | Milestone: Tor: 0.4.1.x-final
Component: Core Tor/Tor | Version:
Severity: Normal | Keywords: 041-should
Actual Points: | Parent ID:
Points: 0.1 | Reviewer:
Sponsor: |
------------------------------+--------------------------------
We have a convention that, to avoid confusion, two directories should
never have headers with the same name. Our `rectify_include_paths.py`
tool takes advantage of this fact to find a canonical path for each
header. But in 0.4.1, we now have two conflicting headers:
{{{
./src/core/or/sendme.h
./src/trunnel/sendme.h
}}}
Let's rename one of these.
--
Ticket URL: <https://trac.torproject.org/projects/tor/ticket/30769>
Tor Bug Tracker & Wiki <https://trac.torproject.org/>
The Tor Project: anonymity online
_______________________________________________
tor-bugs mailing list
tor-bugs@xxxxxxxxxxxxxxxxxxxx
https://lists.torproject.org/cgi-bin/mailman/listinfo/tor-bugs