[Author Prev][Author Next][Thread Prev][Thread Next][Author Index][Thread Index]

Re: [tor-talk] Tor service can't start with "CPU worker" error

On 27 August 2011 17:22, Roger Dingledine <arma@xxxxxxx> wrote:
> On Sat, Aug 27, 2011 at 05:05:06PM -0400, Advrk Aplmrkt wrote:
>> Hello,
>> I've been running a Tor relay for almost 5 days now and it works great!
>> Unfortunately, I rebooted my server (which is running Tor) today, and
>> when I do "service tor status", I get the following:
>> PID file (/var/run/tor/tor.pid) present, but tor (1914) not running
>> I tried:
>> (1) Rebooting the server again
>> (2) running "service tor restart"
>> But that didn't help. So I looked at the logs (info level), and found
>> the following on the last lines:
>> Aug 27 16:53:24.447 [info] choose_good_exit_server_general(): Chose
>> exit server 'TOR1CINIPAC'
>> Aug 27 16:53:24.452 [info] circuit_handle_first_hop(): Next router is
>> [scrubbed]: Connection in progress; waiting.
>> Aug 27 16:53:24.452 [info] cpuworker_main(): CPU worker exiting
>> because Tor process closed connection (either rotated keys or died).
>> There seems to be a problem with the "cpuworker"? But what does that mean?
> It is an "info" level log. It doesn't mean there's a problem with your
> cpuworker. That is a normal log line, either as part of Tor shutting down,
> or as part of Tor rotating some of its keys. If it's the last line in
> your log, my guess is it's part of Tor shutting down.
>> By the way, the default notice level tor.log did not show any errors,
>> but always end with 80% bootstrap as its last line...
>> The Tor I have is version installed via yum from the
>> "torproject" RPM repository as indicated on the Tor website. Also, my
>> system is Scientific Linux 6.1 64-bit, which is RHEL without the
>> brand.
>> Can anyone help with this? I am eager to get my relay up and running
>> again. Thanks.
> Are there no "notice" or "warn" level logs?
> If no, see also
> https://trac.torproject.org/projects/tor/wiki/doc/TorFAQ#MyTorkeepscrashing.
> --Roger

I just checked again, there are no "notice", "warn", nor "err" level
log entries...
I also tried the beta, exact same problem. Should I file a
bug report? If so, I am not really should how I should describe it...
tor-talk mailing list