[Author Prev][Author Next][Thread Prev][Thread Next][Author Index][Thread Index]

Re: chrooting tor

On 16.06.2005 00:37, Thomas Sjögren wrote:
On Thu, Jun 16, 2005 at 12:29:36AM +0200, Florian Mader wrote:

I just tried to chroot my Tor Server  using the Scripts accessable on
http://www.northernsecurity.net/download/ . when running /etc/init.d/tor
I find the following in the log file:

[notice] Tor opening log file.
[notice] Initialized libevent version 1.1 using method epoll
[err] finish_daemon (): /dev/null can't be opened. Exiting.

What does it mean? I'm not a linux guru at all, just experimenting ...
Any ideas?

It means /dev/null wasnt created by the tor-chroot script, the line is
mknod -m 0666 $CHROOTDIR/dev/null c 1 3

I run the scripts on Debian and haven't had any problems with them, they
are not tested on any other distribution or operating system so using
them on something other then Debian might be a gamble.

Hi Thomas,

thanks for the reply (did forget the subject ...). I'm running those scripts on Debian too (Sarge).
When running the tor-chroot script again it says that /var/chroot/tor/dev/null already exists.