[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Problem with RGBA Texture in GLX



> 
> 
> Nathi-huesken@gmx.de wrote:
> 
> > I thing you misunderstood! My Data-Format is not the Problem. If I
> change
> > the seceond GL_RGB/GL_RGBA (the one telling the Data Format of my Data),
> it is
> > not a Problem. But if I change the first one, the System is crashing.
> 
> No - I didn't misunderstand - but the only thing that *should* be able to
> induce a Seg Fault is accessing memory out of range - and in a glTexImage
> call, the obvious chunk of memory is the source image.  So, try the test
> I suggest and we can eliminate (or not) that possibility.

Well, I did that test, I also acced the memory Block befor giving it to
glTexImage. It's perfectly fine!

> The failure of the NeHe tutorial isn't promising though.
> 
> I havn't spent a lot of time working with the very latest nVidia drivers
> (I'm still using v1.0-2960) - and I havn't played with something as
> ancient
> as a TNT-2 for a long time - so it's *possible* there is some kind of
> driver
> bug - but this is a VERY obvious case and I'd be suprised if nobody had
> noticed it before.

I just do not havbe any Idea what it could be. At the same time, I am
nothing like a "Guru" ;).
Just eliminate that source of Error, a working Code-Sample using
Alpha-Textures would be very cool!
I have been searching the web, but I just can't find any ready-to-compile
example.
Well, anyway, thanks a lot for your help!
Nathan

-- 
+++ GMX - Mail, Messaging & more  http://www.gmx.net +++
NEU: Mit GMX ins Internet. GŁnstige DSL- & Modem/ISDN-Tarife!