[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

ok, real problems




very reproduceable.  Select "sign up"

then it don't work.  Looking at the source to the resulting page is:

b>Fatal error</b>:  Maximum execution time exceeded in
<b>includes/functions.php3</b> on line <b>1351</b><br>

I notice that the DB on vodka is taking a lot of hits for object type 8,
and that the active http process on Yukon is eating 40-50% CPU and grows
to almost 40MB of RAM.  After the query times out, the process size
reduces to about 22MB.

Load on Vodka is >=0.05 so that doesn't appear to be it.

I've seen this http memory growth before, but I thought it was mod_perl
related, now I'm thinking PHP.

Also, every now and then, while browsing the site, I'll get "document
returned no data" error.  Turns out were getting httpd's that segfault.
Usually I see this when trying to access a PHP only page like News.

I'm thinking of upgrading to the latest PHP 3.0.12->15.  Comments?
We're pretty behind on Apache too.

--
Aaron Turner, Core Developer       http://vodka.linuxkb.org/~aturner/
Linux Knowledge Base Organization  http://www.linuxkb.org/
Because world domination requires quality open documentation.
aka: aturner@vicinity.com, aturner@pobox.com, ion_beam_head@ashtech.net
The difference between `Unstable' and `Usable' is only two characters: NT