[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

admin.linuxkb.org & SSL



-----BEGIN PGP SIGNED MESSAGE-----


I'm about -> <- close to getting admin working under SSL.  The only
problem I can see so far, is that if you do a POST in an aliased directory
(mot/phpMyAdmin) it barfs with an IO error.  My limited experiance tells
me that the cause is that the browser/server are out of sync with regards
to SSL.  Ie. the browser is sending a non-SSL request and the server is
expecting SSL or vice-versa.  Maybe today at work (gawd, it's already 1am)
I'll put a sniffer on the network and see what the browser is sending.

take a look, and let me know if you have any ideas:

https://admin.linuxkb.org/sqladmin/

Try adding a user, and you'll get the error.  

One thing that might make it easier if I knew how/where we wanted to to
user lookups from.  Jason- do we want to do auth lookups for admin via the
mysql DB or linuxkb DB users table?  I'm leaning towards mysql, so that we
can have different passwords than the non-SSL stuff.

Note, in the mean time, http://admin.linuxkb.org/ still works.

- -- 
Aaron Turner           | Either which way, one half dozen or another. 
aturner@pobox.com      | Check out the Red Hat Linux User's FAQ Online!
www.pobox.com/~aturner | http://www.pobox.com/~aturner/RedHat-FAQ/
All emails from this account are PGP signed.  Lack of a signature is "bad".
PGP Key fingerprint = FB E1 CE ED 57 E4 AB 80  59 6E 60 BF 45 1B 20 E8



-----BEGIN PGP SIGNATURE-----
Version: 2.6.2

iQCVAwUBNuja/TM3jpXy1kJtAQEG5AP/QTCoJCcE4kdLRWpTO+7pTnY80ZvaBmwB
uq6eJy7Qkj4jz9OynVva98kFP9T7kIw4SOR/tLJA6JZWl4qRGe9RAxQNRkBHSL81
pTTX8UAzcMulRmsEPQOAmuuJBUN4gIpa4AnTfC4rm5cKVSJoz0lqOTrxS+2ps1iP
e0Htxdzl4bY=
=wk90
-----END PGP SIGNATURE-----