[Author Prev][Author Next][Thread Prev][Thread Next][Author Index][Thread Index]

Re: Debian Install Broken

I tried what you said & it helped a little, but not a lot. Basically
when I install tor using the apt-get command, it initializes the tor

After search through a few directories, I was able to find the script
that you was telling me about. It is in the "/etc/init.d" directory. I
restarted it by typing "./tor restart". I tried starting it as user
"root" & "debian-tor". I get the following messages:

debian-tor@Phreakx07:/etc/init.d$ ./tor start
Starting tor daemon: tor...
start-stop-daemon: Unable to set initgroups() with gid 111

Phreakx07:/etc/init.d# ./tor start
Starting tor daemon: tor...
Dec 20 16:11:43.537 [notice] tor_init(): Tor v0.0.9.1. This is
experimental software. Do not rely on it for strong anonymity.

It acts likes it's starting while I try to initialize it as root, but
I don't get any messages that I'm connecting to any mixes after that.
Nor does it work when I set Firefox to use socks 5 on port 9050, or
8118 with privoxy. So something isn't working, any other ideas on what
it might be? Thanks for your help!

On Mon, 20 Dec 2004 18:15:20 -0500, Roger Dingledine <arma@xxxxxxx> wrote:
> On Mon, Dec 20, 2004 at 05:38:37PM -0500, Phreakx07 wrote:
> > As of version, the Debian install has been broken
> > for me. I've even tried to reinstall Debian, but I keep getting the
> > same error while executing tor. The error is as follows:
> >
> > Phreakx07:/home/phreakx07# tor
> I'm not a Debian person, but I'll take a stab at this.
> First, it may already be running. Try "ps auxw|grep tor" to find out.
> In any case, that's not how you're supposed to be running it. The Debian
> Tor package creates a separate user for Tor called debian-tor. The deb has
> a script for starting Tor like every other daemon. You should be using it.
> Try something like "/etc/rc.d/tor start"
> --Roger