[Author Prev][Author Next][Thread Prev][Thread Next][Author Index][Thread Index]

Re: More info on my own tor problems

     On Thu, 4 Dec 2008 08:17:18 -0500 Praedor Atrebates <praedor@xxxxxxxxx>
>I have had a long-running problem upgrading to tor-  I usually 
>use Tork as my tor manager (version 0.29.2 rpm - I can't build the latest 
>because I am using kde 4 and it wont build on such a system) and run the 
>configuation wizard after every tor upgrade.  This has worked perfectly up 
>The problem is that no matter what I do, be it configure tor via Tork or do it 
>manually with a text editor, I cannot get tor to run.  It crashes very quickly 
>and, from Tork, produces no useful log information.  It just stops.
>I have now tried with vidalia and I am still unable to run tor but I am 
>getting useful log data:
>Dec 04 08:05:41.407 [Notice] Tor v0.2.1.7-alpha (r17216). This is experimental 
>software. Do not rely on it for strong anonymity. (Running on Linux i686)
>Dec 04 08:05:41.409 [Warning] Unable to open configuration file 
>Dec 04 08:05:41.410 [Error] Reading config failed--see warnings above.
>Dec 04 08:06:24.666 [Notice] Tor v0.2.1.7-alpha (r17216). This is experimental 
>software. Do not rely on it for strong anonymity. (Running on Linux i686)
>Dec 04 08:06:24.669 [Warning] Skipping obsolete configuration option 'Group'
>Dec 04 08:06:24.673 [Notice] Initialized libevent version 1.4.7-stable using 
>method epoll. Good.
>Dec 04 08:06:24.675 [Notice] Opening OR listener on
>Dec 04 08:06:24.679 [Notice] Opening Socks listener on
>Dec 04 08:06:24.682 [Notice] Opening Control listener on
>Dec 04 08:06:24.686 [Warning] Error setting configured groups: Operation not 
>Dec 04 08:06:24.689 [Warning] Failed to parse/validate config: Problem with 
>User value. See logs for details.
>Dec 04 08:06:24.693 [Error] Reading config failed--see warnings above.
>I have no idea what the problem is with the torrc file.  I merely took the 
>sample provided with the software and uncommented the applicable parts (after 
>Tork failed to configure it) and copy it to torrc.  What is the deal with 
>tor-  What has changed vis a vis configuration that appears to break 
>it compared to the any and all of the previous versions?  Most important of 
>all, how do I get past this so I can start running tor again?
     The problem may not actually be in the torrc file.  Check to see whether
you have a startup/shutdown script, perhaps run by /etc/rc on your system,
that specifies --user and --group.  If you do, try removing those arguments
from the command line that starts tor in the script.
     The error messages could be more accurate.

                                  Scott Bennett, Comm. ASMELG, CFIAG
* Internet:       bennett at cs.niu.edu                              *
* "A well regulated and disciplined militia, is at all times a good  *
* objection to the introduction of that bane of all free governments *
* -- a standing army."                                               *
*    -- Gov. John Hancock, New York Journal, 28 January 1790         *