[Author Prev][Author Next][Thread Prev][Thread Next][Author Index][Thread Index]

Re: "Your system clock just jumped" on Debian+VMware ESX

Marco Bonetti wrote:
> On Thu, February 28, 2008 06:14, Lucky Green wrote:
>> NTP:
>> ntp is installed on the guest. ntpq -p shows a solid lock.
> remove ntp from the guest, it causes troubles.
> also, search vmware kb for clock issues, the most common fixes are
> removing ntp services from guest, installing tools on the guest and
> selecting the clock synchronization (with the host).
> another common pitfall is the "bitness" of host and guest: keep 32bit
> hosts with 32bit guests and the same with 64bit, mixing them could raise
> clock problems.
> Long time ago I had the very same problem with a 64bit ubuntu host running
> vmware server and a 32bit debian guest.

Thank you all for your good advice!

I tried several potential fixes. Unfortunately none of them worked.

What I tried so far:

1) removed ntp from the guest
2) Enabled time sync from the guest to the host using "vmware-guest
--cmd "vmx.set_options synctime 0 1" (which, unlike editing the .vmx
file by hand is permanent)
3) verified that the ESX host has the correct time with ntp enabled and
is shown as being in the correct time zone.
4) verified that the hardware clock on both host and guest are set correctly
5) Scoured the VMware forums for advice. I see evidence of drifts, but
not of jumps.

I continue to see Tor report errors of jumps in the system time from
4397-4399 seconds. Strangely, this jump in time does not appear to be
reflected in the time stamp that Tor assigns to the error message.

What I have not yet tried:
I have not tried setting clocksource=pitt and similar grub modifications
suggested in the VMware forums. I don't see how such changes could help
in this case. We are not talking about a slow drift. We are talking
about (supposed) system clocks jumps of over an hour only minutes apart.

Suggestions for next steps would be much appreciated.