[Author Prev][Author Next][Thread Prev][Thread Next][Author Index][Thread Index]

Re: "Your system clock just jumped" on Debian+VMware ESX

On Thu, 28 Feb 2008, Lucky Green wrote:

> I tried several potential fixes. Unfortunately none of them worked.

> 1) removed ntp from the guest
> 2) Enabled time sync from the guest to the host using "vmware-guest
> --cmd "vmx.set_options synctime 0 1" (which, unlike editing the .vmx
> file by hand is permanent)
> 3) verified that the ESX host has the correct time with ntp enabled and
> is shown as being in the correct time zone.
> 4) verified that the hardware clock on both host and guest are set correctly
> 5) Scoured the VMware forums for advice. I see evidence of drifts, but
> not of jumps.
> I continue to see Tor report errors of jumps in the system time from
> 4397-4399 seconds. Strangely, this jump in time does not appear to be
> reflected in the time stamp that Tor assigns to the error message.

maybe it will help getting some more light on the issue if you just install a
cronjob which prints the output of "date" in a file, and then try to see
if the issue is a tor bug or a kernel bug. 4300 secounds are a bit more than
60minutes.. so if its a kernel bug it should happen to other processes too.

Florian Reitmeir