[Author Prev][Author Next][Thread Prev][Thread Next][Author Index][Thread Index]

Re: (FWD) Problems with Tor in user-mode-linux

Hash: SHA1


On Wed, 19 Jan 2005, Roger Dingledine wrote:

> As for why the Tor in CVS may not work, there are known bugs with 2.5/2.6
> kernels, epoll, and the new libevent stuff. We're working on those.

Ok. Will retry when there is a fix.
Meanwhile I will testrun the and the CVS code on a 2.4 kernel.

> Is this running as a client or a server? I assume server, since you
> have multiple tor processes.

This is running as server (bmwanon), but not serving directory.
I retried it without UML on a SuSE-2.4.21 kernel.
After 60 hours there were 11 processes using 140MB RAM and additional 
33MB of swap, with 258 connections and transferring about 350kb/s

 # date ; free ; netstat -tanp|grep tor|wc -l ; ps ax|grep tor|grep -v grep |wc -l 
Sat Jan 22 06:10:51 CET 2005
             total       used       free     shared    buffers     cached
Mem:        968088     957740      10348          0       8696     629024
- -/+ buffers/cache:     320020     648068
Swap:      1052248      93644     958604

the first (parent) process using 56220kb alone.

> As for why Tor memory explodes in user-mode-linux, gosh, I
> don't know. Does user-mode-linux not give back memory that's freed?

I ran several other programs (like mozilla, gaim, apache, postfix, bind) 
in UML and it all worked well.

maybe there is no memory leak and for some reason tor needs 0.7MB per 
connection for normal operation... unlikely.
Unluckily I dont know enough about why and when tor forks and processes 
stop... but for the curious I recorded some outputs of
ps ax| perl -ne 'if(!/tor\.pid/){next} m/^\s*(\d+)/;print $1,"\n"; system 
"grep ^Vm /proc/$1/status"'
that can be found at http://lsmod.de/~bernhard/tor/

Giorgos Pallas problem seems to be related to this.

Bernhard M.