[Author Prev][Author Next][Thread Prev][Thread Next][Author Index][Thread Index]

Re: Newbie needs help

On Friday 24 July 2009 13:25:55 Christian Fromme wrote:
> Hi,
> On Fri, Jul 24, 2009 at 2:18 PM, Bob
> Williams<security@xxxxxxxxxxxxxxxxxxxxx> wrote:
> > On Friday 24 July 2009 13:06:55 Christian Fromme wrote:
> >> Next time you want to kill Tor, check out its process id (`pidof tor`
> >> or `ps ax | grep tor | grep -v grep`) and kill that explicitly via
> >> `kill <pid>`. Make sure you're the same user that started Tor when you
> >> kill it. Check if its still running afterwards (`ps ax | grep tor |
> >> grep -v grep`).
> >
> > Actually, it looks as if the tor process is indestructible :( Neither
> > root nor user bob (that's who started it) can kill it.
> Tried kill -9 <pid>?
Good. That worked. Now when I try to restart it, it says I should start it as 

Jul 24 13:37:23.052 [warn] Error setting groups to gid 112: "Operation not 
permitted". If you set the "User" option, you must start Tor as root.
Jul 24 13:37:23.052 [warn] Failed to parse/validate config: Problem with User 
value. See logs for details.
Jul 24 13:37:23.052 [err] Reading config failed--see warnings above.
/usr/bin/torctl start: tor could not be started
startproc:  exit status of parent of /usr/bin/torctl: 3

I don't remember setting a "User" option, but tor was installed from a package 
obtained from my distro's repositories, so it may have occurred automatically.

Is it OK to run it as root?