[Author Prev][Author Next][Thread Prev][Thread Next][Author Index][Thread Index]

Re: Tor server on NSLU2: ORPort unreachable

Stephen Hildrey wrote:
Eugen wrote:

I want to run a Tor middle node on a NSLU2 device (266Mhz, 32 MB RAM).
I installed Debian etch version on it for ARM platform, and it works great..
But reachability of the ORPort fails...


I tried this a year or two ago and experienced the same problem. Like you say, client functionality was fine (though slow) but it didn't want to work as a Tor node itself.

I don't believe the problem is a network (e.g. port forwarding) issue. I believe the problem is caused by either a) some incompatibility between the current implementation of the OpenSSL libraries and armv5tel, or b) the low spec of the device rendering key generation too slow for the reachability checks.

Ultimately I didn't have time to investigate further, and I have no hard evidence to support either of my theories. That said, I have a known-good Tor configuration that worked on an x86 desktop machine, but not on an armv5tel NSLU2.

Interested to hear how you get on,

I tried different things, and it still not working.
I'm also sure it is not a network configuration issue. So I tried these:

I compiled myself on the device, the development version of tor Running it has the same behaviour as stable version: ORPort not reachable.

I upgrade the Debian distribution from etch(stable) to lenny (testing) so I could use the new ARM port "armel" ( http://wiki.debian.org/ArmEabiPort ). It says here that the floating point performance is "very much faster", and also that "armel" adds additional features. I'm not sure if and how much Tor uses floating point operations, but I said I'll give it a try.

So, I installed lenny, armel port, and Tor package. Again, same behaviour: everything looks fine, except Tor fails to see if ORPort is reacheable...

No progress so far...