[Author Prev][Author Next][Thread Prev][Thread Next][Author Index][Thread Index]

Re: Tor is out

On Sun, May 15, 2005 at 12:38:04PM +0200, Ron Davis wrote:
> I just installed it on FreeBSD 4.11. Being a relative layman at FreeBSD,
> I encountered just one minor "problem" during installation. 
> After I had installed libevent 1.1, I ran ./configure for Tor. It
> reported "libevent library not found".
> Somewhere on the net, I found this string:
> CPPFLAGS="-I/usr/local/include" LDFLAGS="-L/usr/local/lib" \
> ./configure
> ...which worked.

Right, this is because your libevent installs itself in /usr/local/,
yet your system isn't configured to look for anything there.

I consider this a bug with the bsd's. :(

Maybe you should build libevent with --prefix=/usr ?

We've been pondering making Tor's autoconf automatically append
-I/usr/local/include and -L/usr/local/lib if they seem needed, but this
is a dangerous path to go down.

Our current thoughts are, if it looks like you don't have libevent,
your autoconf should go see if it looks like it's in /usr/local but not
in your ld.so.conf or includepath, and if so, spit out an error message
that tells you to run the command you quote above if you really mean that.

Is there a better way to do this? Should we just automate it anyway and
accept the fact that sometimes the bsd folks will get weird behavior if
they're relying on the current (broken) paths?