[Author Prev][Author Next][Thread Prev][Thread Next][Author Index][Thread Index]

Re: Tor not working

I've restarted Tor several times, even restarted my system, and I still get the 503 error, even though Terminal and Vidalia both say Tor is running. I'm on OS X PPC and Vidalia is a fat binary, but I stripped the Intel code from it, as I had before this all started happening.

The output of "ps auxwww | grep Tor" is this:

424   2.7  0.1    27376    424  p1  S+    7:43PM   0:00.01 grep Tor

I just tried launching Vidalia and going to the Tor menu to turn it "On" and tried Firefox again, and it worked. But this makes no sense, since I've never had have Vidalia running to use Tor when I was running 10.3.9.

Any idea what's up with that, and do I really have to launch Vidalia every time I want to use Tor?


--Spin Doctor

On Oct 3, 2006, at 7:33 PM, phobos@xxxxxxxxxx wrote:

On Tue, Oct 03, 2006 at 05:34:08PM -0500, nil.bitbucket@xxxxxxxxx wrote 1.4K bytes in 48 lines about:
: What else can I do? This is very frustrating.

	If you are using the vidalia-tor bundle, Privoxy is already
	configured to forward to Tor for you.  If you know Terminal at
	all, run the following commands:

	"sudo /Library/StartupItems/Tor/Tor stop"
	"sudo /Library/StartupItems/Tor/Tor start"
	This will restart Tor completely.  If privoxy continues to
	return 503 errors, something else is broken in the pathway
	between Tor and Privoxy.  One interesting thing is that your
	"ps" output showed "Tor ControlPort 9051".  This isn't a standard
	Tor command line.

	The output of "ps auxwww | grep Tor" for a default Tor
	installation on OSX should show a Tor process as:
	/Library/Tor/tor -f /Library/Tor/torrc --runasdaemon 1 --pidfile
	/var/run/Tor.pid --datadirectory /Library/Tor/var/lib/tor --user
	_tor --group daemon --log notice file /var/log/tor/tor.log

	Are you on OSX x86 or PPC?  The packages for OSX are
	fat binaries.

	I'm happy to help out further.