[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: G++ libraries

> The 2.7 C++ compiler is allegedly lacking support of many modern C++
> fetaures.
Indeed, 2.7 wasn't fully compliant with the "standard" that existed
when it was released. Namespaces and run-time type identification were
partially implemented, and templates and exceptions were still somewhat
incomplete and buggy, though mostly usable. All of those areas except
for namespaces are supposed to be basically up to snuff in 2.8.

> Another strategy would be to go 2.8 and provide a 2.8 library to
> people not having it.  Problem is: does 2.8 work with libc5?
> Apparently yes.  However people using a glibc2.8 compiled for libc5
> will have problems with their c++ apps the day they upgrade to a RH
> 5.x.
But, is this a problem specific to libstdc++? What about all those 
other shared libraries, where the version number did not change from 
libc5 to glibc distribs (e.g. the X shared libraries), won't a lot of
other libc5 applications stop working for the same reason?
My impression is a re-install is usually simpler than an upgrade to glibc 
anyways, assuming it's an ordinary user who didn't have to put too much
effort into the configuration to begin with. Otherwise they will be in for
some fun anyways, and the 2.8 c++ libs pose no special difficulty.

> Finally we could go 2.8 only for glibc packages, remain in 2.7 for
> libc and accept some software will not be available to libc5 users.
I don't see that libc5 should be any different. If you have RH 5.0 users
upgrade to 2.8 then you can have the SUSE, RH 4.2, etc. do it too; just 
make the decision on whether the few apps that positively require 2.8 are 
worth the trouble of switching.
(I'm assuming here that for the sake of consistency, any c++ apps previously
built would be re-built, yes?)

In summary, my opinion is that we should be consistant between libc/glibc, but
I don't know whether it's worth the trouble or not, somebody else who knows 
what cool applications have taken to requiring g++ 2.8 should decide that :-)

                              S. Lockwood