[Author Prev][Author Next][Thread Prev][Thread Next][Author Index][Thread Index]

Re: Holy shit I caught 1

Mike Perry <mikepery@xxxxxxxxxx> wrote:

> Thus spake Fabian Keil (freebsd-listen@xxxxxxxxxxxxx):
> > > So even so, it's unsettling.. You download some app, iso, video, or
> > > whatever via Privoxy and it kindly tells you there's a temporary
> > > failure mid-binary stream. How nice of it.
> > 
> > How nice of you to back up your claims with enough information
> > to reproduce the problem. Which error message did you get and
> > did you verify the problem with another client?
> I assumed that anyone who actually cared to reproduce the problem
> would just run the script, because that's all I did.

You claimed:

|Privoxy is dumping temporary failure messages mid-stream into
|the binaries, yet keeping the sizes exactly the same.

therefore I assumed you actually verified that it is a Privoxy
problem, so it should be reproducible without running any
scripts. I wouldn't complain if you had just written:

|My script doesn't work reliable and I haven't investigated
|the reason yet.

> Running the script out of the box with the default settings
> will reproduce the problem within a few hours of scanning. You will
> get tons of corrupted Torpark exes in your docs dir. Seems to really
> like Torpark more than anything else. Probably cause its the biggest.
> Here is the error:
>   <title>503 - Connect failed (Privoxy@xxxxxxxxxxxxxxxxxxxxx)</title>
>           This is <a href="http://www.privoxy.org/";>Privoxy</a> 3.0.3
> on localhost.localdomain (, port 8118<!-- @if-can-toggle-start -->,

I doubt that it was inserted mid-stream.

> > Especially the "keeping the size exactly the same" part sounds
> > more like a problem in the fetching client. Are you sure that
> > your application doesn't retry failed fetch attempts without
> > caring about status codes?
> Client is wget. Apparently it does retry after failure. Manpage says
> nothing about status codes. Maybe it doesn't know what to do with 503.

Not exactly Privoxy's fault, is it?
> > Is it impossible that the download was started but the connection
> > broke down, your application tried again and got a "404 no such
> > domain", saved the error message in the binary stream and tried
> > again with a adjusted byte range?  
> Yeah, I'm thinking the connection most likely broke down, wget retried
> and tried to continue the stream, but Privoxy came back with its 503
> status error page instead, probably not something wget was looking
> for. Wget probably tried once more after that connection closed, and
> picked up the stream again.

So do you still think it's a Privoxy bug?
> Unfortunately my copy of curl is ignoring HTTP proxy environment
> variables and --proxy command line settings, so I can't check to see
> if it has the same property.

Well lucky me, I have working copies of curl and fetch lying
around. I will give your script a try, to see how they behave.


Attachment: signature.asc
Description: PGP signature