[Author Prev][Author Next][Thread Prev][Thread Next][Author Index][Thread Index]

Re: irssi+tsocks: can't connect to ssl-secured irc-server


I can partly confirm it. On my first try the exact same happened to me.
Second and third test didn't work due to a connection refused.
Fourth attempt worked:

/whois alex
18:54 -!-  ircname  : Alexander W. Janssen
18:54 -!-           : is connecting from *@cv-dv.net -> GatewayToHeaven

5th attempt: Connection refused.
6th - 10th: Connection worked.

I tried to run strace on the irssi-process but that didn't work
(Unable to connect server irc.mozilla.org port 6697 [Broken pipe]) - I
guess this is a sideeffect of tsocks preloading other libraries. No
idea how to truss/strace it.

Interestingly the problem you're describing only happens every now and
then on my machine:
$ uname -a
Linux castor 2.6.16-2-686-smp #1 SMP Mon Aug 21 12:29:28 CEST 2006
i686 GNU/Linux
$ cat /etc/debian_version
$ irssi --version
irssi 0.8.10 (20051211 0941)

Sorry, I don't think I can help any further. Maybe you're lucky and
this is only a temporary error occuring every now and then. Otherwise
contacting the irssi-maintainers could be a start.

Cheers, Alex.

"I am tired of all this sort of thing called science here... We have spent
millions in that sort of thing for the last few years, and it is time it
should be stopped."
-- Simon Cameron, U.S. Senator, on the Smithsonian Institute, 1901.