[Author Prev][Author Next][Thread Prev][Thread Next][Author Index][Thread Index]

Re: Here we go again...tor just stops

I'm just throwing this out here, because something similar happened to me recently.
The app I was working with would run fine for a few hours, maybe even a day.  Then it would just die, halt, or freeze my system.

After a week or so of trying to debug it, I remembered rule 1 in troubleshooting, check the physical hardware first to make sure it is working correctly.  So I ran a memtest, and sure enough, I had a few bad spots in my RAM.

I wasted weeks thinking it was either:
1) bad code
2) bad OS
3) bad VM configuration

and it wasn't any of those.  Go figure....
Perhaps run a memtest just to be sure it isn't hardware related??  Just a thought..

- Kyle

On Wed, Jan 21, 2009 at 1:22 PM, Praedor Atrebates <praedor@xxxxxxxxx> wrote:
This is getting annoying to point of wanting to simply drop tor.

As of this morning I had been running tor- through Tork 0.29.2 without
hitch (Mandriva linux 2009.0).  Any time I have tried to progress to anything
beyond this version I run into the same problem every time:  tor will either not
run or, more likely, will run for some period of time and then simply stop
without any error messages to explain the termination.

This morning, I decided to give tor- a try.  Built and installed
just fine and started up just fine.  It was running for at least several hours
without hitch but then I had to leave for a meeting.  I'm gone for 2 1/2 hours
only to come back and find that tor has stopped without so much as a single
message anywhere on the system.  Nothing in the tork logs either.

What the heck is going on?
"An imbalance between rich and poor is the oldest and most fatal ailment of all