[Author Prev][Author Next][Thread Prev][Thread Next][Author Index][Thread Index]

geoip file open error message

     I'm running  Whenever tor starts or reloads torrc in
response to a SIGHUP, I get a message like this:

Jul 29 07:35:58.028 [info] geoip_load_file(): Failed to open GEOIP file /usr/local/share/tor/geoip.

However, the file is actually present and was originally owned by root, group
wheel, with 644 permissions.  I tried changing the owner and group both to
_tor, but it made no difference.  I tried putting a symlink to it by the same
name ("geoip") into /var/db/tor.  Also no luck.
     I took a look at geoip.c, and it looks like fopen() is returning an error,
but it is not apparent to me what the problem is.  If anyone has an idea,
please let me know.  It doesn't seem to be a serious problem for my server
because it's not involved in any bridging operations, but it bothers me to see
the error message every time.  Thanks in advance.

                                  Scott Bennett, Comm. ASMELG, CFIAG
* Internet:       bennett at cs.niu.edu                              *
* "A well regulated and disciplined militia, is at all times a good  *
* objection to the introduction of that bane of all free governments *
* -- a standing army."                                               *
*    -- Gov. John Hancock, New York Journal, 28 January 1790         *