[Author Prev][Author Next][Thread Prev][Thread Next][Author Index][Thread Index]

osx installer problems on several machines

# Forwarding these emails here along with the fix, from or-dev


How do I file a bug report? I ran into this FAIL on two seperate Apple machines last night at Tor Night at the VanHackSpace. Tried on a fresh install here with same results. I still have not narrowed down what is causing the problem, it looks like the browser is not connecting to the polipo from what I can tell.

any ideas?



# Installed new system 10.6 base no updates on MacBook

# Installed Firefox 3.5.4

# Installed vidalia package: vidalia-bundle-

#ran the "Install Torbutton for Firefox" script

#Started Vidalia tor start fine and connects to a circuit fine, log below:

Oct 30 19:58:23.209 [Notice] Tor v0.2.1.20. This is experimental software. Do not rely on it for strong anonymity. (Running on Darwin i386) Oct 30 19:58:23.224 [Notice] Initialized libevent version 1.4.12- stable using method kqueue. Good.
Oct 30 19:58:23.224 [Notice] Opening Socks listener on
Oct 30 19:58:23.224 [Notice] Opening Control listener on
Oct 30 19:58:23.568 [Notice] This version of Tor ( is newer than any recommended version in its series, according to the directory authorities. Recommended versions are:,,,,,,, Oct 30 19:58:24.216 [Notice] We now have enough directory information to build circuits. Oct 30 19:58:24.217 [Notice] Bootstrapped 80%: Connecting to the Tor network. Oct 30 19:58:24.394 [Notice] Bootstrapped 85%: Finishing handshake with first hop. Oct 30 19:58:27.874 [Notice] Bootstrapped 90%: Establishing a Tor circuit. Oct 30 19:58:32.793 [Notice] Tor has successfully opened a circuit. Looks like client functionality is working.
Oct 30 19:58:32.795 [Notice] Bootstrapped 100%: Done.

#Started Firefox and it gives me the alert:

The proxy server is refusing connections
Firefox is configured to use a proxy server that is refusing connections.

   *   Check the proxy settings to make sure that they are correct.

* Contact your network administrator to make sure the proxy server is

#top tells me their all the correct things are running:

202- polipo 0.0 00:00.00 1 0 14 28 120K 240K 492K 201- tor 0.0 00:01.27 1 0 18 43 5344K 1128K 9304K 197- Vidalia 0.0 00:08.25 6 1 107 188 14M 31M 36M

From what I can tell the proxy settings in FF are set correctly:

HTTP Proxy
SSL Proxy

and it looks like all the settings are correct in Vidalia


cat torrc

# This file was generated by Tor; if you edit it, comments will not be preserved # The old torrc file was renamed to torrc.orig.1 or similar, and Tor will ignore it

# If set, Tor will accept connections from the same machine (localhost only) # on this port, and allow those connections to control the Tor process using
# the Tor Control Protocol (described in control-spec.txt).
ControlPort 9051
# Store working data, state, keys, and caches here.
DataDirectory /Users/sand/.tor/
HashedControlPassword 16:E8C7050BABCE652860183B560A0ABBC869B5E85B54562EC092FE637AD1
# Where to send logging messages.  Format is minSeverity[-maxSeverity]
# (stderr|stdout|syslog|file FILENAME).
Log notice stdout


cat vidalia.conf

InterfaceStyle=Macintosh (aqua)


Geometry=@ByteArray(\x1\xd9\xd0\xcb \0\x1\0\0\0\0\x1\xc2\0\0\0\xe9\0\0\x5\x37\0\0\x2\xba \0\0\x1\xc2\0\0\0\xff\0\0\x5\x37\0\0\x2\xba\0\0\0\0\0\0)

Geometry=@ByteArray(\x1\xd9\xd0\xcb\0\x1\0\0\0\0\x3\x32\0\0\0w \0\0\x4\xcc\0\0\x2\x37\0\0\x3\x32\0\0\0\x8d\0\0\x4\xcc \0\0\x2\x37\0\0\0\0\0\0)

Geometry=@ByteArray(\x1\xd9\xd0\xcb\0\x1\0\0\0\0\x1h \0\0\0\xf8\0\0\x2\x82\0\0\x1<\0\0\x1h\0\0\x1\xe\0\0\x2\x82\0\0\x1< \0\0\0\0\0\0)

Geometry=@ByteArray(\x1\xd9\xd0\xcb\0\x1\0\0\0\0\x1h \0\0\0\xf8\0\0\x4\xb3\0\0\x3\x61\0\0\x1h\0\0\x1\xe \0\0\x4\xb3\0\0\x3\x61\0\0\0\0\0\0)

Geometry=@ByteArray(\x1\xd9\xd0\xcb\0\x1\0\0\0\0\0\xb9\0\0\0\xcd\0\0\x3 (\0\0\x3\x16\0\0\0\xb9\0\0\0\xe3\0\0\x3(\0\0\x3\x16\0\0\0\0\0\0)

Geometry="@ByteArray(\x1\xd9\xd0\xcb\0\x1\0\0\0\0\0,\0\0\0Y\0\0\x2Z \0\0\x2(\0\0\0,\0\0\0o\0\0\x2Z\0\0\x2(\0\0\0\0\0\0)"





To unsubscribe, send an e-mail to majordomo@xxxxxxxxxxxxxx with
unsubscribe or-talk    in the body. http://archives.seul.org/or/talk/