[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: somewhat done

Bjarke Hammersholt Roune wrote:

>Well, the "somewhat" is pretty important  :)
>Anyways, the namespace and name stuff is finished.

Ok, I took the thing, added it into the existing dir structure, removed the
"ppf_" prefixes (from both files and symbols) while I was at it and
uploaded it as PenguinPlay-0.0.1.tar.gz for the impatient (it's quite a
mess now though)

I'll spend the rest of the evening hacking the stuff and hopefully I can
upload an updated package before dawn ;)

>I've changed the serialization interface a little. Basically, File declares
>virtual functions for  both serializing data in AND out. In the File
>implementation, however, they throw EUnavailable exceptions. So, as
>PakFileFile doesn't support serializing to a target, only from one, it
>simply doesn't implement the proper virtual functions, but rather enherits
>them from File. That, of course, means that calling a serialization function
>that serializes to a source, will result in an exception of type
>EUnavailable if the object it is beeing called on is a PakFileFile.
>What do you think about this change?

Looks good. Yes.

>I also completely removed the PakWThing class. It was without use in the new


>Anyways, I don't think I need your help with serialization. Should be done
>pretty soon (as in hopefully tomorrow or the day after that, probably
>tomorrow if my homework doesn't kill me).


>There are some implementation files that have had their implementation
>commented out, because I simply didn't know what to do with them, and
>ppf_URLInfo is generating alot of errors too. If you don't have anything to
>do, that probably would be some good things to fix.


>btw, I actually got PFile to compile. I had to exclude ppf_URLInfo from the
>build, but oterwise things went smoothly. Well, ok, if you forget about the
>fact that I've commented out a few implementation files, which caused 64
>build errors... ;)



Drive A: not responding...Formatting C: instead