[Author Prev][Author Next][Thread Prev][Thread Next][Author Index][Thread Index]

Re: .onion sites fail to load with: (waiting for rendezvous desc)


after reading this I went ahead and with the help of Phobos compiled an installed trunk.

On Feb 16, 2008, at 11:02 PM, gogogadgetnecktie@xxxxxxxxxxx wrote:

On Sat, 16 Feb 2008 21:46:54 +0100, "Karsten Loesing"
<karsten.loesing@xxxxxxx> said:
Some days ago there was a guy on #tor with a similar problem. You? :)

Nope, that was me :)

I just tried to access two hidden services. Worked fine. But obviously,
there is a bug that we should track down. Maybe you can help us with

I'd like to help

I can connect to http://duskgytldkxiuqc6.onion/ without a problem, but
others including core.onion, hidden wiki, Freenode's hidden IRC server,
and a few others don't work as they used to. I attempt only known &
verified as working .onion sites from others. Non-fuctional (down)
.onion sites show a different message in terminal unrelated to this bug.

I had a somewhat strange behaviour. I was able to connect to the example hidden service, but not the v2 test service. trying to access the v2 test service, I got the message "[Notice] Tried for 120 seconds to get a connection to [scrubbed]:80. Giving up. (waiting for rendezvous desc)" a bit later, I could access the v2 test page without a problem, but core.onion still throws the above error message. The strange thing is that a made-up onion address gives a different error message in the log:

Trying to access http://duskgytldkxi2qc6.onion/ (almost the same as a above, but changed one letter) I get a "[Notice] Closing stream for '[scrubbed].onion': hidden service is unavailable (try again later)." in the logs :)

What happens when
you restart Tor and try again? What if you wait for some minutes after
starting Tor before trying?

All tries fail.

Same here, it does not matter how long Tor has been running

Did you try to compile
and run current trunk? Unfortunately one bug fix for
turned out to be erroneous and was reverted in current trunk. But I
doubt that it's the one causing the problem you describe.

unfortunately, this doesn't seem to be the problem :(


Attachment: PGP.sig
Description: This is a digitally signed message part