[Author Prev][Author Next][Thread Prev][Thread Next][Author Index][Thread Index]

Re: is this a bandwidth problem? my IP is a TOR exit, the client works and the server doesn't

"Rip Rock" <riprock.adres.nl@xxxxxxxxx> wrote:

> On 7/22/07, Roger Dingledine <arma@xxxxxxx> wrote:
> >
> >
> > >
> > > I think the problem might be a lack of bandwidth.
> >
> > No, the problem is that your ports aren't reachable.
> Okay, the problem is my ports.  And  because my logs had lacked the error
> messages described by Fabian, I guess I have socks4 where I ought to have
> socks4a, although
> I had thought that I had socks4a because my Privoxy config file has the
> line:
> #
> forward-socks4a / localhost:9050 .
> But of course the little dot prevents the forwarding from being used.

There's nothing wrong with the dot. It indicates that
there's no HTTP proxy after the socks proxy.

> So I tried taking out the "." and LittleSnitch reported that Privoxy was
> now trying to access the net when I tried to find the hidden service.

That's because invalid configuration directives are ignored
(and valid forward-socks4a directives end either with a dot
or with a HTTP proxy address).

Have a look at:
to see which of your configuration directives are ignored.

> I now see that there is an error:
> Jul 22 23:53:09:137 [Notice] Rend stream is 120 seconds late. Giving up
> on addre
> ss '[scrubbed].onion'.
> Now, the fact that I have that would lead me to think I have socks4a,

At least you had it at "Jul 22 23:53:09:137" ...

> but " example.noconnect" leads to an identical error page, so maybe I
> don't have socks4a, or maybe some other thing is going wrong with the
> 9050 mentioned in the file and the 8118 mentioned on the error page.

I think you messed up your Privoxy configuration file
while debugging this issue.

> > I imagine the worst-case scenario is that I'll be unable to resolve any
> > > .onion URLs until
> >
> > Does http://6sxoyfb3h2nvok2d.onion/ load for you? You may have to try
> > it several times.
> That address opens immediately with the message:
> [quote]
> The hidden wiki is gone. If you set up a new one and post the link to the
> or-talk list I'll link it from here. 06/07/07.
> Some Hans Zaagman suggested in a post to
> or-talk<http://archives.seul.org/or/talk/Jun-2007/msg00215.html>to use
> http://hy2644uxnz6zwt6c.onion/hidden/ as a replacement. 07/07/07.
> [/quote]

So this hidden service appears to be working.

> The problem comes when I try to open
> http://hy2644uxnz6zwt6c.onion/hidden/
> which always takes at least 30 seconds, usually much longer, and results
> in a  404 error.

This hidden service doesn't work for me either,
maybe it's just not running.

> So anyway I went into the config file of Privoxy and added the following
> below the forward socks4a:
> forward-socks4a / localhost:9050
> forward-socks4a / localhost:8118
> forward         192.168.*.*/
> forward         10.*.*.*/
> forward         127.*.*.*/
> This was inspired by reading the faq/configuration file.  However,
> neither the new hidden wiki, nor example.noconnect, show any new
> behaviors -- they both show the same error page, except for the URL.

That's probably because none of these lines use correct syntax
(and the second one is probably wrong anyway as it would overrule
the first one and it's unlikely that Tor is listening at port 8118).

The configuration file of the official Privoxy release
should contain the same (valid) lines as:

Attachment: signature.asc
Description: PGP signature