[Author Prev][Author Next][Thread Prev][Thread Next][Author Index][Thread Index]

Re: AdvTor

Fabian Keil wrote:
If you are using a Privoxy version more recent than 3.0.9
(released in 2008), you can use SOCKS5 which will allow Tor
to provide Privoxy with a more detailed problem description.

My mistake, I assume that means that v3.0.16 does indeed do this DNS reporting.

With a more recent version I get:

| fk@r500 ~ $lynx --dump http://www.cobblers.za/
|    503
| | This is [1]Privoxy 3.0.17 on Privoxy-Jail.local (, port 8118,
|        enabled
|    Warning:
|       This Privoxy version is based on UNRELEASED code and not intended for
|       production systems!
|       Use at your own risk. See the [2]license for details.
| | Forwarding failure | | Privoxy was unable to socks5-forward your request
|       [3]http://www.cobblers.za/ through tor-jail: SOCKS5 host unreachable
| | Just [4]try again to see if this is a temporary problem, or check your
|    [5]forwarding settings and make sure that all forwarding servers are
|    working correctly and listening where they are supposed to be
|    listening.

And Tor says:
Oct 09 14:00:19.571 [notice] Have tried resolving or connecting to address 'www.cobblers.za' at 3 different places. Giving up.

After reading what you say about this retrying, I assume that the long waits I got while it re-tried other circuits does mean that it was DNS resolution failure and not refusal to serve/connect to a page that we are dealing with here.

To unsubscribe, send an e-mail to majordomo@xxxxxxxxxxxxxx with
unsubscribe or-talk    in the body. http://archives.seul.org/or/talk/